blob: c7dcb3beb36b24d6b0eba95810bc503a52946933 [file] [log] [blame]
Alexander Filippov3985d5f2020-06-08 12:51:56 +03001SUMMARY = "Tatlin network configuration"
2DESCRIPTION = "This is default network configuration for the Tatlin's node."
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6PR = "r1"
7
8inherit allarch
9inherit systemd
10
11RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
12SYSTEMD_SERVICE_${PN} = "setup-vlan4004.service"
13
14S = "${WORKDIR}"
15SRC_URI = " \
16 file://00-bmc-eth0.4004.0.network \
17 file://00-bmc-eth0.4004.1.network \
18 file://00-bmc-eth0.network \
19 file://eth0.4004.netdev \
20 file://setup-vlan4004.service \
21 file://setup-vlan4004.sh \
22"
23
24do_install() {
25 mkdir -p ${D}${sysconfdir}/systemd/network
26 install -m 0644 eth0.4004.netdev 00-bmc-eth0.network \
27 00-bmc-eth0.4004.0.network 00-bmc-eth0.4004.1.network \
28 ${D}${sysconfdir}/systemd/network/
29 mkdir -p ${D}${bindir} ${D}${systemd_system_unitdir}
30 install setup-vlan4004.sh ${D}${bindir}/
31 install -m 0644 setup-vlan4004.service ${D}${systemd_system_unitdir}/
32}
33
34FILES_${PN} = " \
35 ${sysconfdir}/systemd/network/00-bmc-eth0.4004.0.network \
36 ${sysconfdir}/systemd/network/00-bmc-eth0.4004.1.network \
37 ${sysconfdir}/systemd/network/00-bmc-eth0.network \
38 ${sysconfdir}/systemd/network/eth0.4004.netdev \
39 ${bindir}/setup-vlan4004.sh \
40"