blob: a9a2cec68f939b705ddefe65ac6fb5a613baa051 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Common code for generating core reference images
2#
3# Copyright (C) 2007-2011 Linux Foundation
4
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005# IMAGE_FEATURES control content of the core reference images
6#
7# By default we install packagegroup-core-boot and packagegroup-base-extended packages;
8# this gives us working (console only) rootfs.
9#
10# Available IMAGE_FEATURES:
11#
12# - x11 - X server
13# - x11-base - X server with minimal environment
14# - x11-sato - OpenedHand Sato environment
15# - tools-debug - debugging tools
16# - eclipse-debug - Eclipse remote debugging support
17# - tools-profile - profiling tools
18# - tools-testapps - tools usable to make some device tests
19# - tools-sdk - SDK (C/C++ compiler, autotools, etc.)
20# - nfs-server - NFS server
21# - nfs-client - NFS client
22# - ssh-server-dropbear - SSH server (dropbear)
23# - ssh-server-openssh - SSH server (openssh)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024# - hwcodecs - Install hardware acceleration codecs
25# - package-management - installs package management tools and preserves the package manager database
26# - debug-tweaks - makes an image suitable for development, e.g. allowing passwordless root logins
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027# - empty-root-password
28# - allow-empty-password
29# - post-install-logging
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030# - dev-pkgs - development packages (headers, etc.) for all installed packages in the rootfs
31# - dbg-pkgs - debug symbol packages for all installed packages in the rootfs
32# - doc-pkgs - documentation packages for all installed packages in the rootfs
33# - ptest-pkgs - ptest packages for all ptest-enabled recipes
34# - read-only-rootfs - tweaks an image to support read-only rootfs
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035# - splash - bootup splash screen
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036#
37FEATURE_PACKAGES_x11 = "packagegroup-core-x11"
38FEATURE_PACKAGES_x11-base = "packagegroup-core-x11-base"
39FEATURE_PACKAGES_x11-sato = "packagegroup-core-x11-sato"
40FEATURE_PACKAGES_tools-debug = "packagegroup-core-tools-debug"
41FEATURE_PACKAGES_eclipse-debug = "packagegroup-core-eclipse-debug"
42FEATURE_PACKAGES_tools-profile = "packagegroup-core-tools-profile"
43FEATURE_PACKAGES_tools-testapps = "packagegroup-core-tools-testapps"
44FEATURE_PACKAGES_tools-sdk = "packagegroup-core-sdk packagegroup-core-standalone-sdk-target"
45FEATURE_PACKAGES_nfs-server = "packagegroup-core-nfs-server"
46FEATURE_PACKAGES_nfs-client = "packagegroup-core-nfs-client"
47FEATURE_PACKAGES_ssh-server-dropbear = "packagegroup-core-ssh-dropbear"
48FEATURE_PACKAGES_ssh-server-openssh = "packagegroup-core-ssh-openssh"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049FEATURE_PACKAGES_hwcodecs = "${MACHINE_HWCODECS}"
50
51
52# IMAGE_FEATURES_REPLACES_foo = 'bar1 bar2'
53# Including image feature foo would replace the image features bar1 and bar2
54IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
55
56# IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
57# An error exception would be raised if both image features foo and bar1(or bar2) are included
58
59MACHINE_HWCODECS ??= ""
60
61CORE_IMAGE_BASE_INSTALL = '\
62 packagegroup-core-boot \
63 packagegroup-base-extended \
64 \
65 ${CORE_IMAGE_EXTRA_INSTALL} \
66 '
67
68CORE_IMAGE_EXTRA_INSTALL ?= ""
69
70IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
71
72inherit image