blob: 2b4fb97df262665eca3a1572867601d023020a7e [file] [log] [blame]
Brad Bishopf3fd2882019-06-21 08:06:37 -04001SUMMARY = "RISC-V Open Source Supervisor Binary Interface (OpenSBI)"
2DESCRIPTION = "OpenSBI aims to provide an open-source and extensible implementation of the RISC-V SBI specification for a platform specific firmware (M-mode) and a general purpose OS, hypervisor or bootloader (S-mode or HS-mode). OpenSBI implementation can be easily extended by RISC-V platform or System-on-Chip vendors to fit a particular hadware configuration."
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=c36118b4f615f9da37635f2a7ac8ccaf"
5DEPENDS += "dtc-native"
6
7require opensbi-payloads.inc
8
9inherit autotools-brokensep
10
11SRCREV = "ca20ac0cd4c099006d4eea4d9ac7bd7b58e2ae0f"
12SRC_URI = "git://github.com/riscv/opensbi.git \
13 file://0001-Makefile-Don-t-specify-mabi-or-march.patch \
14 file://0002-lib-Create-a-sbi_ipi_data-structure.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19SRC_URI[md5sum] = "621f38d8205ef5fb185e4055025e73df"
20SRC_URI[sha256sum] = "07f18b73abf3b85aabe5bead19a923716c100d30eb58033459f39c3a224be300"
21
22EXTRA_OEMAKE += "PLATFORM=${RISCV_SBI_PLAT} I=${D}"
23# If RISCV_SBI_PAYLOAD is set then include it as a payload
24EXTRA_OEMAKE_append = " ${@riscv_get_extra_oemake_image(d)} ${@riscv_get_extra_oemake_fdt(d)}"
25
26# Required if specifying a custom payload
27do_compile[depends] += "${@riscv_get_do_compile_depends(d)}"
28
29do_install_append() {
30 # In the future these might be required as a dependency for other packages.
31 # At the moment just delete them to avoid warnings
32 rm -r ${D}/include
33 rm -r ${D}/platform/${RISCV_SBI_PLAT}/lib
34 rm -r ${D}/platform/${RISCV_SBI_PLAT}/firmware/payloads
35}
36
37do_deploy () {
38 install -d ${DEPLOY_DIR_IMAGE}
39 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.* ${DEPLOY_DIR_IMAGE}/
40 install -m 755 ${D}/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.* ${DEPLOY_DIR_IMAGE}/
41}
42
43addtask deploy after do_install
44
45FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_jump.*"
46FILES_${PN} += "/platform/${RISCV_SBI_PLAT}/firmware/fw_payload.*"
47
48COMPATIBLE_HOST = "(riscv64|riscv32).*"
49INHIBIT_PACKAGE_STRIP = "1"