blob: 80c559fefb82be790eebed1f8a66ea1a1e1632fc [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "C implementation of createrepo."
2HOMEPAGE = "https://github.com/rpm-software-management/createrepo_c/wiki"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7SRC_URI = "git://github.com/rpm-software-management/createrepo_c \
8 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
9 "
10
Brad Bishopf3fd2882019-06-21 08:06:37 -040011SRCREV = "f390af98c8f1bb04010e293ea864eae160f75879"
Brad Bishopc342db32019-05-15 21:57:59 -040012
13S = "${WORKDIR}/git"
14
Brad Bishop15ae2502019-06-18 21:44:24 -040015DEPENDS = "expat curl glib-2.0 libxml2 openssl bzip2 zlib file sqlite3 xz rpm libmodulemd"
Brad Bishopc342db32019-05-15 21:57:59 -040016DEPENDS_append_class-native = " file-replacement-native"
17
18inherit cmake pkgconfig bash-completion distutils3-base
19
20EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DWITH_ZCHUNK=OFF"
21
22BBCLASSEXTEND = "native nativesdk"
23
24# Direct createrepo to read rpm configuration from our sysroot, not the one it was compiled in
25do_install_append_class-native() {
26 create_wrapper ${D}/${bindir}/createrepo_c \
27 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm
28}
29
30do_install_append_class-nativesdk() {
31 create_wrapper ${D}/${bindir}/createrepo_c \
32 RPM_CONFIGDIR=${SDKPATHNATIVE}${libdir_nativesdk}/rpm
33 rm -rf ${D}/etc
34}