blob: 5feaeea13917dca73d2f9e9fab43b473891aab7d [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "0d70833650a552e0af742882ba84f2ee"
9SRC_URI[sha256sum] = "f371cbfd63f879065422b58fa6b81e21870cd791ef6e11d4528608204aa4dcfb"
10
11inherit autotools native
12
13EXTRA_OECONF = "--disable-nls"
14
15# We don't want to reconfigure things as it would require 'perlnative' to be
16# used.
17do_configure() {
18 oe_runconf
19}
20
21do_install_append () {
22 # Make sure we use /usr/bin/env perl
23 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
24}