blob: d7c83edce337dfc7da74cd6afa8864eefe318f5b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = " A library providing C and Python (libcURL like) API for downloading linux repository metadata and packages."
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
5SRC_URI = "git://github.com/rpm-software-management/librepo.git \
6 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
7 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
8 "
9
Brad Bishopf3fd2882019-06-21 08:06:37 -040010SRCREV = "2eb0a27031956fd98340ca2707f03abb7b780372"
Brad Bishopc342db32019-05-15 21:57:59 -040011
12S = "${WORKDIR}/git"
13
14DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
15
16inherit cmake distutils3-base pkgconfig
17
18EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3 -DENABLE_TESTS=OFF -DENABLE_DOCS=OFF -DWITH_ZCHUNK=OFF"
19
20BBCLASSEXTEND = "native nativesdk"
21