blob: dc07a1809e705083b431aa88c14e2099912b2614 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
14LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
Brad Bishopf3fd2882019-06-21 08:06:37 -040018DEPENDS = "slang popt python3"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
21 file://fix_SHAREDDIR.patch \
22 file://cross_ar.patch \
23 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
24 file://pie-flags.patch \
25 file://0001-detect-gold-as-GNU-linker-too.patch \
26"
27
28SRC_URI[md5sum] = "70b288f821234593a8e7920e435b259b"
29SRC_URI[sha256sum] = "8d66ba6beffc3f786d4ccfee9d2b43d93484680ef8db9397a4fb70b5adbb6dbc"
30
31S = "${WORKDIR}/newt-${PV}"
32
Brad Bishopf3fd2882019-06-21 08:06:37 -040033inherit autotools-brokensep python3native python3-dir
Brad Bishopd7bf8c12018-02-25 22:55:05 -050034
Brad Bishopf3fd2882019-06-21 08:06:37 -040035EXTRA_OECONF = "--without-tcl --with-python"
36
37EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038
39CLEANBROKEN = "1"
40
41export CPPFLAGS
42
Brad Bishopf3fd2882019-06-21 08:06:37 -040043PACKAGES_prepend = "whiptail ${PN}-python "
44
45RDEPENDS_${PN}-python += "python3-core"
46FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050047
48do_configure_prepend() {
49 sh autogen.sh
50}
51
52do_compile_prepend() {
53 # Make sure the recompile is OK
54 rm -f ${B}/.depend
55}
56
57FILES_whiptail = "${bindir}/whiptail"
58
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059BBCLASSEXTEND = "native nativesdk"