blob: 58c7864c304dd1dc69b391e3040bab6be9e83ccf [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit Control"
3DESCRIPTION = "The Linux trace toolkit is a suite of tools designed \
4to extract program execution details from the Linux operating system \
5and interpret them."
6
7LICENSE = "GPLv2 & LGPLv2.1"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=01d7fc4496aacf37d90df90b90b0cac1 \
9 file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://lgpl-2.1.txt;md5=0f0d71500e6a57fd24d825f33242b9ca"
11
12DEPENDS = "liburcu popt libxml2 util-linux"
13RDEPENDS_${PN} = "libgcc"
Brad Bishopf3fd2882019-06-21 08:06:37 -040014RDEPENDS_${PN}-ptest += "make perl bash gawk babeltrace procps perl-module-overloading coreutils util-linux kmod lttng-modules sed"
Brad Bishop19323692019-04-05 15:28:33 -040015RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
16RDEPENDS_${PN}-ptest_append_libc-musl = " musl-utils"
17# babelstats.pl wants getopt-long
18RDEPENDS_${PN}-ptest += "perl-module-getopt-long"
19
20PYTHON_OPTION = "am_cv_python_pyexecdir='${PYTHON_SITEPACKAGES_DIR}' \
21 am_cv_python_pythondir='${PYTHON_SITEPACKAGES_DIR}' \
22 PYTHON_INCLUDE='-I${STAGING_INCDIR}/python${PYTHON_BASEVERSION}${PYTHON_ABI}' \
23"
24PACKAGECONFIG ??= "lttng-ust"
25PACKAGECONFIG[python] = "--enable-python-bindings ${PYTHON_OPTION},,python3 swig-native"
26PACKAGECONFIG[lttng-ust] = "--with-lttng-ust, --without-lttng-ust, lttng-ust"
27PACKAGECONFIG[kmod] = "--with-kmod, --without-kmod, kmod"
28PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
29PACKAGECONFIG_remove_arc = "lttng-ust"
30
31SRC_URI = "https://lttng.org/files/lttng-tools/lttng-tools-${PV}.tar.bz2 \
32 file://x32.patch \
33 file://run-ptest \
34 file://lttng-sessiond.service \
35 file://0001-Fix-tests-link-libpause_consumer-on-liblttng-ctl.patch \
36 file://0002-Fix-test-skip-test_getcpu_override-on-single-thread-.patch \
37 file://0003-Fix-test-unit-the-tree-origin-can-be-a-symlink-itsel.patch \
38 file://0004-Skip-when-testapp-is-not-present.patch\
39 file://0005-Tests-use-modprobe-to-test-for-the-presence-of-lttng.patch \
40 file://0006-Tests-check-for-lttng-modules-presence.patch \
41 file://0007-Fix-getgrnam-is-not-MT-Safe-use-getgrnam_r.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040042 file://0008-Fix-check-for-lttng-modules-presence-before-testing.patch \
Brad Bishop19323692019-04-05 15:28:33 -040043 "
44
45SRC_URI[md5sum] = "e88c521b5da6bb48a8187af633336ecc"
46SRC_URI[sha256sum] = "f05df52bbebf8ce88d1b29e9e98cfc957d2ed738a345118018237ebdb581537c"
47
48inherit autotools ptest pkgconfig useradd python3-dir manpages systemd
49
50SYSTEMD_SERVICE_${PN} = "lttng-sessiond.service"
51SYSTEMD_AUTO_ENABLE = "disable"
52
53USERADD_PACKAGES = "${PN}"
54GROUPADD_PARAM_${PN} = "tracing"
55
56FILES_${PN} += "${libdir}/lttng/libexec/* ${datadir}/xml/lttng \
57 ${PYTHON_SITEPACKAGES_DIR}/*"
58FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
59FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
60
61# Since files are installed into ${libdir}/lttng/libexec we match
62# the libexec insane test so skip it.
63# Python module needs to keep _lttng.so
64INSANE_SKIP_${PN} = "libexec dev-so"
65INSANE_SKIP_${PN}-dbg = "libexec"
66
67do_install_append () {
68 # install systemd unit file
69 install -d ${D}${systemd_unitdir}/system
70 install -m 0644 ${WORKDIR}/lttng-sessiond.service ${D}${systemd_unitdir}/system
71}
72
73do_install_ptest () {
74 for f in Makefile tests/Makefile tests/utils/utils.sh tests/regression/tools/save-load/load-42*.lttng tests/regression/tools/save-load/configuration/load-42*.lttng ; do
75 install -D "${B}/$f" "${D}${PTEST_PATH}/$f"
76 done
77
78 for f in config/tap-driver.sh config/test-driver src/common/config/session.xsd src/common/mi-lttng-3.0.xsd; do
79 install -D "${S}/$f" "${D}${PTEST_PATH}/$f"
80 done
81
82 # Prevent 'make check' from recursing into non-test subdirectories.
83 sed -i -e 's!^SUBDIRS = .*!SUBDIRS = tests!' "${D}${PTEST_PATH}/Makefile"
84
85 # We don't need these
86 sed -i -e '/dist_noinst_SCRIPTS = /,/^$/d' "${D}${PTEST_PATH}/tests/Makefile"
87
88 # We shouldn't need to build anything in tests/utils
89 sed -i -e 's!am__append_1 = . utils!am__append_1 = . !' \
90 "${D}${PTEST_PATH}/tests/Makefile"
91
92 # Copy the tests directory tree and the executables and
93 # Makefiles found within.
94 for d in $(find "${B}/tests" -type d -not -name .libs -printf '%P ') ; do
95 install -d "${D}${PTEST_PATH}/tests/$d"
96 find "${B}/tests/$d" -maxdepth 1 -executable -type f \
97 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
98 # Take all .py scripts for tests using the python bindings.
99 find "${B}/tests/$d" -maxdepth 1 -type f -name "*.py" \
100 -exec install -t "${D}${PTEST_PATH}/tests/$d" {} +
101 test -r "${B}/tests/$d/Makefile" && \
102 install -t "${D}${PTEST_PATH}/tests/$d" "${B}/tests/$d/Makefile"
103 done
104
105 for d in $(find "${B}/tests" -type d -name .libs -printf '%P ') ; do
106 for f in $(find "${B}/tests/$d" -maxdepth 1 -executable -type f -printf '%P ') ; do
107 cp ${B}/tests/$d/$f ${D}${PTEST_PATH}/tests/`dirname $d`/$f
108 case $f in
109 *.so)
110 install -d ${D}${PTEST_PATH}/tests/$d/
111 ln -s ../$f ${D}${PTEST_PATH}/tests/$d/$f
112 # Remove any rpath/runpath to pass QA check.
113 chrpath --delete ${D}${PTEST_PATH}/tests/$d/$f
114 ;;
115 esac
116 done
117 done
118
119 #
120 # Use the versioned libs of liblttng-ust-dl.
121 #
122 ustdl="${D}${PTEST_PATH}/tests/regression/ust/ust-dl/test_ust-dl.py"
123 if [ -e $ustdl ]; then
124 sed -i -e 's!:liblttng-ust-dl.so!:liblttng-ust-dl.so.0!' $ustdl
125 fi
126
127 install ${B}/tests/unit/ini_config/sample.ini ${D}${PTEST_PATH}/tests/unit/ini_config/
128
129 # We shouldn't need to build anything in tests/regression/tools
130 sed -i -e 's!^SUBDIRS = tools !SUBDIRS = !' \
131 "${D}${PTEST_PATH}/tests/regression/Makefile"
132
133 # Prevent attempts to update Makefiles during test runs, and
134 # silence "Making check in $SUBDIR" messages.
135 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
136 sed -i -e '/Makefile:/,/^$/d' -e '/%: %.in/,/^$/d' \
137 -e '/echo "Making $$target in $$subdir"; \\/d' \
138 -e 's/^srcdir = \(.*\)/srcdir = ./' \
139 -e 's/^builddir = \(.*\)/builddir = ./' \
140 -e 's/^all-am:.*/all-am:/' \
141 {} +
142
143 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
144 touch -r "${B}/Makefile" {} +
145
146 #
147 # Need to stop generated binaries from rebuilding by removing their source dependencies
148 #
149 sed -e 's#\(^test.*OBJECTS.=\)#disable\1#g' \
150 -e 's#\(^test.*DEPENDENCIES.=\)#disable\1#g' \
151 -e 's#\(^test.*SOURCES.=\)#disable\1#g' \
152 -e 's#\(^test.*LDADD.=\)#disable\1#g' \
153 -i ${D}${PTEST_PATH}/tests/unit/Makefile
154
155 # Substitute links to installed binaries.
156 for prog in lttng lttng-relayd lttng-sessiond lttng-consumerd lttng-crash; do
157 exedir="${D}${PTEST_PATH}/src/bin/${prog}"
158 install -d "$exedir"
159 case "$prog" in
160 lttng-consumerd)
161 ln -s "${libdir}/lttng/libexec/$prog" "$exedir"
162 ;;
163 *)
164 ln -s "${bindir}/$prog" "$exedir"
165 ;;
166 esac
167 done
168}