blob: 460e05a44506d9bd10a5f0ad5da0bdba99c5132c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Build tools needed by external modules"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5inherit kernel-arch
6inherit pkgconfig
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10S = "${WORKDIR}"
11
12do_configure[depends] += "virtual/kernel:do_shared_workdir openssl-native:do_populate_sysroot"
13do_compile[depends] += "virtual/kernel:do_compile_kernelmodules"
14
Brad Bishopf3fd2882019-06-21 08:06:37 -040015DEPENDS += "bc-native bison-native"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
17EXTRA_OEMAKE = " HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCPP="${BUILD_CPP}""
18
19# Build some host tools under work-shared. CC, LD, and AR are probably
20# not used, but this is the historical way of invoking "make scripts".
21#
22do_configure() {
23 unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
24 oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}" AR="${KERNEL_AR}" \
25 -C ${STAGING_KERNEL_DIR} O=${STAGING_KERNEL_BUILDDIR} scripts prepare
26
27}