blob: 9076d9460192ce08353acb17bc013e6cf83b49ba [file] [log] [blame]
Brad Bishopf3fd2882019-06-21 08:06:37 -04001SUMMARY = "Wireless Central Regulatory Domain Database"
2HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
3SECTION = "net"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=07c4f6dea3845b02a18dc00c8c87699c"
6
7SRC_URI = "https://www.kernel.org/pub/software/network/${BPN}/${BP}.tar.xz"
8SRC_URI[md5sum] = "4b5ba3f089db7fdb7b9daae6a7c1f2cb"
9SRC_URI[sha256sum] = "cd917ed86b63ce8d93947979f1f18948f03a4ac0ad89ec25227b36ac00dc54bf"
10
11inherit bin_package allarch
12
13do_install() {
14 install -d -m0755 ${D}${nonarch_libdir}/crda
15 install -d -m0755 ${D}${sysconfdir}/wireless-regdb/pubkeys
16 install -m 0644 regulatory.bin ${D}${nonarch_libdir}/crda/regulatory.bin
17 install -m 0644 sforshee.key.pub.pem ${D}${sysconfdir}/wireless-regdb/pubkeys/sforshee.key.pub.pem
18
19 install -m 0644 -D regulatory.db ${D}${nonarch_base_libdir}/firmware/regulatory.db
20 install -m 0644 regulatory.db.p7s ${D}${nonarch_base_libdir}/firmware/regulatory.db.p7s
21}
22
23# Install static regulatory DB in /lib/firmware for kernel to load.
24# This requires Linux kernel >= v4.15.
25# For kernel <= v4.14, inherit the kernel_wireless_regdb.bbclass
26# (in meta-networking) in kernel's recipe.
27PACKAGES = "${PN}-static ${PN}"
28RCONFLICTS_${PN} = "${PN}-static"
29
30FILES_${PN}-static = " \
31 ${nonarch_base_libdir}/firmware/regulatory.db \
32 ${nonarch_base_libdir}/firmware/regulatory.db.p7s \
33"
34
35# Native users might want to use the source of regulatory DB.
36# This is for example used by Linux kernel <= v4.14 and
37# kernel_wireless_regdb.bbclass in meta-networking.
38do_install_append_class-native() {
39 install -m 0644 -D db.txt ${D}${libdir}/crda/db.txt
40}
41
42RSUGGESTS_${PN} = "crda"
43
44BBCLASSEXTEND = "native"