blob: aeb558b2b737ec01a294102538451650dea7400d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Random number generator daemon"
Brad Bishop15ae2502019-06-18 21:44:24 -04002DESCRIPTION = "Check and feed random data from hardware device to kernel"
3AUTHOR = "Philipp Rumpf, Jeff Garzik <jgarzik@pobox.com>, \
4 Henrique de Moraes Holschuh <hmh@debian.org>"
5HOMEPAGE = "https://github.com/nhorman/rng-tools"
6BUGTRACKER = "https://github.com/nhorman/rng-tools/issues"
Brad Bishop19323692019-04-05 15:28:33 -04007LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Brad Bishop15ae2502019-06-18 21:44:24 -04009DEPENDS = "sysfsutils"
Brad Bishop19323692019-04-05 15:28:33 -040010
Brad Bishop15ae2502019-06-18 21:44:24 -040011SRC_URI = "\
12 git://github.com/nhorman/rng-tools.git \
Brad Bishopf3fd2882019-06-21 08:06:37 -040013 file://fix-rngd-fail-to-stop.patch \
Brad Bishop15ae2502019-06-18 21:44:24 -040014 file://init \
15 file://default \
16 file://rngd.service \
Brad Bishop19323692019-04-05 15:28:33 -040017"
Brad Bishopf3fd2882019-06-21 08:06:37 -040018SRCREV = "9fc873c5af0e392632e6b736938b811f7ca97251"
Brad Bishop15ae2502019-06-18 21:44:24 -040019
Brad Bishop19323692019-04-05 15:28:33 -040020S = "${WORKDIR}/git"
21
22inherit autotools update-rc.d systemd pkgconfig
23
Brad Bishop19323692019-04-05 15:28:33 -040024PACKAGECONFIG ??= "libgcrypt libjitterentropy"
25PACKAGECONFIG_libc-musl = "libargp libjitterentropy"
Brad Bishop15ae2502019-06-18 21:44:24 -040026
Brad Bishop19323692019-04-05 15:28:33 -040027PACKAGECONFIG[libargp] = "--with-libargp,--without-libargp,argp-standalone,"
28PACKAGECONFIG[libgcrypt] = "--with-libgcrypt,--without-libgcrypt,libgcrypt,"
29PACKAGECONFIG[libjitterentropy] = "--enable-jitterentropy,--disable-jitterentropy,libjitterentropy"
Brad Bishopf3fd2882019-06-21 08:06:37 -040030PACKAGECONFIG[libp11] = "--with-pkcs11,--without-pkcs11,libp11 openssl"
Brad Bishop19323692019-04-05 15:28:33 -040031PACKAGECONFIG[nistbeacon] = "--with-nistbeacon,--without-nistbeacon,curl libxml2 openssl"
32
Brad Bishop15ae2502019-06-18 21:44:24 -040033INITSCRIPT_NAME = "rng-tools"
34INITSCRIPT_PARAMS = "start 03 2 3 4 5 . stop 30 0 6 1 ."
35
36SYSTEMD_SERVICE_${PN} = "rngd.service"
37
Brad Bishop19323692019-04-05 15:28:33 -040038# Refer autogen.sh in rng-tools
39do_configure_prepend() {
40 cp ${S}/README.md ${S}/README
41}
42
43do_install_append() {
Brad Bishop15ae2502019-06-18 21:44:24 -040044 install -Dm 0644 ${WORKDIR}/default ${D}${sysconfdir}/default/rng-tools
45 install -Dm 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rng-tools
46 install -Dm 0644 ${WORKDIR}/rngd.service \
47 ${D}${systemd_system_unitdir}/rngd.service
48 sed -i \
49 -e 's,@SYSCONFDIR@,${sysconfdir},' \
50 -e 's,@SBINDIR@,${sbindir},' \
51 ${D}${sysconfdir}/init.d/rng-tools \
52 ${D}${systemd_system_unitdir}/rngd.service
Brad Bishop19323692019-04-05 15:28:33 -040053}