blob: 155331417a96616a2c59aab06f523311536c3010 [file] [log] [blame]
Adriana Kobylak6161f452015-10-19 14:15:04 -04001SUMMARY = "Temp placeholder for skeleton function"
2DESCRIPTION = "Temp placeholder for skeleton repository"
3HOMEPAGE = "http://github.com/openbmc/skeleton"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
Brad Bishopc88c37c2015-10-21 20:24:23 -04008inherit obmc-phosphor-chassis-mgmt
Brad Bishopc88c37c2015-10-21 20:24:23 -04009inherit obmc-phosphor-fan-mgmt
10inherit obmc-phosphor-flash-mgmt
11inherit obmc-phosphor-policy-mgmt
12inherit obmc-phosphor-sensor-mgmt
13inherit obmc-phosphor-system-mgmt
Adriana Kobylak6161f452015-10-19 14:15:04 -040014
KennethWilke84f9c742016-02-17 13:24:04 -060015DEPENDS += "glib-2.0 systemd"
Norman Jamesa91766b2016-02-10 11:34:19 -060016RDEPENDS_${PN} += "python-subprocess python-compression libsystemd"
Adriana Kobylak6161f452015-10-19 14:15:04 -040017SRC_URI += "git://github.com/openbmc/skeleton"
Adriana Kobylak6161f452015-10-19 14:15:04 -040018
Patrick Williamse0d4a8f2016-04-01 15:04:31 -050019# RDEPEND on pflash if the openpower-pflash machine feature is set.
20PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}"
21PACKAGECONFIG[openpower-pflash] = ",,,pflash"
22
Brad Bishopf441ae32016-05-03 10:51:48 -040023SRCREV = "264009617c231447d6c8fc61264cf3c6ea7f49d5"
Adriana Kobylak6161f452015-10-19 14:15:04 -040024
Brad Bishop59ca1fd2015-10-28 08:13:43 -050025S = "${WORKDIR}"
Adriana Kobylak6161f452015-10-19 14:15:04 -040026
27do_compile() {
Adriana Kobylak75b8b382015-10-29 11:14:29 -050028 oe_runmake -C git
Patrick Williamse0d4a8f2016-04-01 15:04:31 -050029
30 # Remove deprecated files.
31 rm ${S}/git/bin/pflash
Adriana Kobylak6161f452015-10-19 14:15:04 -040032}
33
34do_install() {
Brad Bishop59ca1fd2015-10-28 08:13:43 -050035 source=${S}/git
36
Adriana Kobylak6161f452015-10-19 14:15:04 -040037 install -d ${D}/${sbindir} ${D}${libdir}
Adriana Kobylak75b8b382015-10-29 11:14:29 -050038 for i in ${source}/bin/*; do
Adriana Kobylak6161f452015-10-19 14:15:04 -040039 install $i ${D}/${sbindir}
40 done
Adriana Kobylak75b8b382015-10-29 11:14:29 -050041 for i in ${source}/lib/*; do
42 install $i ${D}/${libdir}
43 done
Adriana Kobylak6161f452015-10-19 14:15:04 -040044}