Brian Ma | d421169 | 2023-07-05 10:46:47 +0800 | [diff] [blame] | 1 | SUMMARY = "EDID to JSON tool" |
| 2 | DESCRIPTION = "This is a collection of tools that helps you work with \ |
| 3 | EDID files, by parsing them as well as by converting between EDID \ |
| 4 | binaries and JSON files." |
| 5 | HOMEPAGE = "https://github.com/rpavlik/edid-json-tools" |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=dc64d2d7c140d9bd69045b5abaede3a7" |
| 8 | |
| 9 | SRC_URI = "git://github.com/rpavlik/edid-json-tools.git;branch=main;protocol=https" |
| 10 | SRCREV = "1cb9416c10c8186b572fbbc98b51b67c00ec2e70" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit setuptools3 |
| 15 | PIP_INSTALL_PACKAGE = "edid-json-tools" |
| 16 | |
| 17 | RDEPENDS:${PN} += " \ |
| 18 | python3-click \ |
| 19 | " |
| 20 | BBCLASSEXTEND = "native" |