blob: db88af093ee01a8e87b524c05fe9054c27829ac6 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "Library providing automatic proxy configuration management"
2DESCRIPTION = "libproxy provides interfaces to get the proxy that will be \
3used to access network resources. It uses various plugins to get proxy \
4configuration via different mechanisms (e.g. environment variables or \
5desktop settings)."
6HOMEPAGE = "https://github.com/libproxy/libproxy"
7BUGTRACKER = "https://github.com/libproxy/libproxy/issues"
8SECTION = "libs"
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
11 file://src/libproxy/proxy.c;beginline=1;endline=20;md5=bb9a177ef1c995311070f34c5638a402 \
12 "
13
14DEPENDS = "glib-2.0"
15
16SRC_URI = "git://github.com/libproxy/libproxy;protocol=https;branch=main"
17SRCREV = "29d51a611f28af0bdbd51a5779cc8df264c8dcff"
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig gobject-introspection vala gi-docgen
21GIDOCGEN_MESON_OPTION = 'docs'
22
23PACKAGECONFIG ?= ""
24PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl"
25PACKAGECONFIG[config-gnome] = "-Dconfig-gnome=true,-Dconfig-gnome=false,gsettings-desktop-schemas"
26PACKAGECONFIG[pacrunner-duktape] = "-Dpacrunner-duktape=true,-Dpacrunner-duktape=false,duktape"
27
28FILES:${PN} += "${libdir}/${BPN}/${PV}/modules"