blob: 99f55f4a14f3c20978cb11e72bc8a55c79bb068c [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Generic XKB keymap library"
2DESCRIPTION = "libxkbcommon is a keymap compiler and support library which \
3processes a reduced subset of keymaps as defined by the XKB specification."
4HOMEPAGE = "http://www.xkbcommon.org"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e525ed9809e1f8a07cf4bce8b09e8b87"
6LICENSE = "MIT & MIT-style"
7
8DEPENDS = "util-macros flex-native bison-native"
9
10SRC_URI = "http://xkbcommon.org/download/${BPN}-${PV}.tar.xz"
11
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012SRC_URI[sha256sum] = "a2202f851e072b84e64a395212cbd976ee18a8ee602008b0bad02a13247dbc52"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14UPSTREAM_CHECK_URI = "http://xkbcommon.org/"
15
16inherit meson pkgconfig
17
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018EXTRA_OEMESON = "-Denable-docs=false -Denable-xkbregistry=false"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)}"
21PACKAGECONFIG[x11] = "-Denable-x11=true,-Denable-x11=false,libxcb xkeyboard-config,"
22PACKAGECONFIG[wayland] = "-Denable-wayland=true,-Denable-wayland=false,wayland-native wayland wayland-protocols,"
23
24# Fix a following runtime error:
25# xkbcommon: ERROR: couldn't find a Compose file for locale "C"
26RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', 'libx11-compose-data', d)}"