blob: 165e192cb15153dd6da8d407bb868d791ddf8529 [file] [log] [blame]
Brad Bishopf6355e42020-12-08 14:30:50 -05001SUMMARY = "VMcore extraction tool"
2DESCRIPTION = "\
3 This program is used to extract a subset of the memory available either \
4 via /dev/mem or /proc/vmcore (for crashdumps). It is used to get memory \
5 images without extra uneeded information (zero pages, userspace programs, \
6 etc). \
7"
8HOMEPAGE = "http://makedumpfile.sourceforge.net"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
11LICENSE = "GPLv2.0"
12
13DEPENDS = "bzip2 zlib elfutils"
14RDEPENDS_${PN}-tools = "perl ${PN}"
15
16# arm and aarch64 would compile but has never been tested upstream. mips would not compile.
17#
18COMPATIBLE_HOST = "(x86_64|i.86|powerpc|arm|aarch64).*-linux"
19
20PACKAGES =+ "${PN}-tools"
21FILES_${PN}-tools = "${bindir}/*.pl"
22
23SRC_URI = "\
24 ${SOURCEFORGE_MIRROR}/makedumpfile/${BPN}-${PV}.tar.gz \
25 file://0001-makedumpfile-replace-hardcode-CFLAGS.patch \
26 file://0002-mem_section-Support-only-46-bit-for-MAX_PHYSMEM_BITS.patch \
27 file://0001-PATCH-Remove-duplicated-variable-definitions.patch \
28"
29SRC_URI[md5sum] = "808ef840ca49ca6bfde77c097cf429f5"
30SRC_URI[sha256sum] = "e702fbdf62b4cd829a76e46f3e24eb3fc7501918b85ebdcd8baef4f53d6ee2c8"
31
32UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/makedumpfile/files/makedumpfile/"
33UPSTREAM_CHECK_REGEX = "makedumpfile/(?P<pver>\d+(\.\d+)+)/"
34
35SECTION = "base"
36
37# If we do not specify TARGET, makedumpfile will build for the host but use the
38# target gcc.
39#
40EXTRA_OEMAKE = "\
41 LINKTYPE=static \
42 TARGET=${TARGET_ARCH} \
43"
44
45do_install () {
46 mkdir -p ${D}/usr/bin
47 install -m 755 ${S}/makedumpfile ${D}/usr/bin
48 install -m 755 ${S}/makedumpfile-R.pl ${D}/usr/bin
49
50 mkdir -p ${D}/usr/share/man/man8
51 install -m 644 ${S}/makedumpfile.8.gz ${D}/usr/share/man/man8
52
53 mkdir -p ${D}/usr/share/man/man5
54 install -m 644 ${S}/makedumpfile.conf.5.gz ${D}/usr/share/man/man5
55
56 mkdir -p ${D}/etc/
57 install -m 644 ${S}/makedumpfile.conf ${D}/etc/makedumpfile.conf.sample
58}