blob: 6ab9f6cbe7bbda9e5df4a1ee9a4c0cf961d4b338 [file] [log] [blame]
Brad Bishopf6355e42020-12-08 14:30:50 -05001SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
7SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c"
8
9inherit autotools
10
11# This is a hand-maintained aclocal.m4 but our autotools class currently deletes
12# aclocal.m4.
13EXTRA_AUTORECONF += "--exclude=aclocal"
14
15EXTRA_OECONF = "--disable-nls"
16
17do_install_append () {
18 # Make sure we use /usr/bin/env perl
19 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
20}
21
22BBCLASSEXTEND = "native nativesdk"