blob: add9ff41a10bcfd140a980ae64021f16aa318954 [file] [log] [blame]
Brad Bishopf6355e42020-12-08 14:30:50 -05001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
12DEPENDS = "glib-2.0"
13
14GNOMEBASEBUILDCLASS = "meson"
15inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages upstream-version-is-even
16
17SRC_URI += "file://run-ptest \
18 file://0001-scanner-use-macro-instead-of-cast-to-convert-pointer.patch \
19"
20SRC_URI[archive.md5sum] = "4d4bb9837f6d31e32d0ce658ae135f68"
21SRC_URI[archive.sha256sum] = "720c5f4379513dc11fd97dc75336eb0c0d3338c53128044d9fabec4374f4bc47"
22
23PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
24
25do_install_append() {
26 if ! ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then
27 rm -rf ${D}${datadir}/installed-tests ${D}${libexecdir}
28 fi
29}
30
31BBCLASSEXTEND = "native nativesdk"
32
33# Currently it's not possible to disable gettext in Meson, so we need to force
34# this back on.
35USE_NLS_class-native = "yes"