blob: 065b5c61f39f09fe4b8e3e5d49a7948789138d50 [file] [log] [blame]
Jeremy Kerr882199e2016-03-17 17:35:27 +08001SUMMARY = "OpenBMC console daemon"
2DESCRIPTION = "Daemon to handle UART console connections"
3HOMEPAGE = "http://github.com/openbmc/obmc-console"
4PR = "r1"
5
6inherit obmc-phosphor-license
7inherit obmc-phosphor-systemd
8inherit autotools
9
10TARGET_CFLAGS += "-fpic -O2"
11
12SRC_URI += "git://github.com/openbmc/obmc-console"
Brad Bishopf75c9602016-08-30 14:14:24 -040013SRC_URI += "file://${PN}.conf"
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080014
Patrick Williams25abb6d2016-08-31 09:40:02 -050015SRCREV = "87e344cd6bd848f886e226c8d58ffe4da77ce4bc"
Jeremy Kerr882199e2016-03-17 17:35:27 +080016
Brad Bishopf75c9602016-08-30 14:14:24 -040017SYSTEMD_SERVICE_${PN} = " \
18 ${PN}.service \
19 ${PN}-ssh.socket \
20 ${PN}-ssh@.service \
21 "
Jeremy Kerr2a9a9d72016-04-12 13:10:12 +080022
Jeremy Kerr882199e2016-03-17 17:35:27 +080023do_install_append() {
24 install -m 0755 -d ${D}${sysconfdir}
25 install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf
Jeremy Kerr882199e2016-03-17 17:35:27 +080026}
27
28S = "${WORKDIR}/git"