Deepak Kodihalli | 75c32cc | 2017-02-05 10:39:06 -0600 | [diff] [blame] | 1 | SUMMARY = "Parser for OpenPOWER-format FRU VPD" |
| 2 | DESCRIPTION = "Parse OpenPOWER-format FRU VPD and update inventory" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit autotools pkgconfig |
| 6 | inherit openpower-fru-vpd |
| 7 | inherit pythonnative |
| 8 | inherit obmc-phosphor-systemd |
| 9 | |
| 10 | require ${PN}.inc |
| 11 | |
Deepak Kodihalli | 09fb624 | 2017-02-15 04:48:20 -0600 | [diff] [blame] | 12 | SRC_URI += "file://70-op-vpd.rules" |
| 13 | |
Deepak Kodihalli | 75c32cc | 2017-02-05 10:39:06 -0600 | [diff] [blame] | 14 | DEPENDS += " \ |
| 15 | virtual/openpower-fru-vpd-layout \ |
| 16 | virtual/openpower-fru-inventory \ |
| 17 | sdbusplus \ |
| 18 | phosphor-logging \ |
| 19 | python-mako-native \ |
| 20 | python-pyyaml-native \ |
| 21 | autoconf-archive-native \ |
| 22 | " |
| 23 | |
| 24 | RDEPENDS_${PN} += " \ |
| 25 | sdbusplus \ |
| 26 | phosphor-logging \ |
| 27 | " |
| 28 | |
| 29 | SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service" |
| 30 | |
| 31 | S = "${WORKDIR}/git" |
| 32 | |
| 33 | EXTRA_OECONF = "FRU_YAML=${STAGING_DIR_NATIVE}${vpdlayout_datadir}/layout.yaml" |
| 34 | |
| 35 | do_install_append() { |
| 36 | SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name} |
| 37 | DEST=${D}${inventory_envdir} |
| 38 | install -d ${DEST} |
| 39 | install ${SRC}/inventory ${DEST} |
Deepak Kodihalli | 09fb624 | 2017-02-15 04:48:20 -0600 | [diff] [blame] | 40 | |
| 41 | install -d ${D}/${base_libdir}/udev/rules.d/ |
| 42 | install ${WORKDIR}/70-op-vpd.rules ${D}/${base_libdir}/udev/rules.d/ |
Deepak Kodihalli | 75c32cc | 2017-02-05 10:39:06 -0600 | [diff] [blame] | 43 | } |