blob: b5c43200d62919efbf6955ec8665e7110ab10ea1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux Trace Toolkit Userspace Tracer 2.x"
2DESCRIPTION = "The LTTng UST 2.x package contains the userspace tracer library to trace userspace codes."
3HOMEPAGE = "http://lttng.org/ust"
4BUGTRACKER = "https://bugs.lttng.org/projects/lttng-ust"
5
6LICENSE = "LGPLv2.1+ & MIT & GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=c963eb366b781252b0bf0fdf1624d9e9 \
8 file://snprintf/snprintf.c;endline=32;md5=d3d544959d8a3782b2e07451be0a903c \
9 file://snprintf/various.h;endline=31;md5=89f2509b6b4682c4fc95255eec4abe44"
10
11inherit autotools lib_package manpages
12
13DEPENDS = "liburcu util-linux"
14RDEPENDS_${PN}-bin = "python3-core"
15
16# For backwards compatibility after rename
17RPROVIDES_${PN} = "lttng2-ust"
18RREPLACES_${PN} = "lttng2-ust"
19RCONFLICTS_${PN} = "lttng2-ust"
20
21PE = "2"
22
23SRC_URI = "https://lttng.org/files/lttng-ust/lttng-ust-${PV}.tar.bz2 \
24 file://lttng-ust-doc-examples-disable.patch \
25 "
Brad Bishopf8caae32019-03-25 13:13:56 -040026SRC_URI[md5sum] = "ffcfa8c1ba9a52f002d240e936e9afa2"
27SRC_URI[sha256sum] = "9e8420f90d5f963f7aa32bc6d44adc1e491136f687c69ffb7a3075d33b40852b"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028
29CVE_PRODUCT = "ust"
30
31PACKAGECONFIG[manpages] = "--enable-man-pages, --disable-man-pages, asciidoc-native xmlto-native libxslt-native"
32
33do_install_append() {
34 # Patch python tools to use Python 3; they should be source compatible, but
35 # still refer to Python 2 in the shebang
36 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${bindir}/lttng-gen-tp
37}