blob: afc36d46e6720d791412403fa8e9031a5f3d7014 [file] [log] [blame]
Adriana Kobylak2fae8ec2018-09-24 14:27:15 -05001SUMMARY = "Network Block Device Proxy"
2HOMEPAGE = "https://github.com/openbmc/jsnbd"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
7
8inherit autotools pkgconfig
9
10DEPENDS += "json-c"
11DEPENDS += "udev"
12
Adriana Kobylak723136d2018-10-03 15:16:29 -050013RDEPENDS_${PN} += "nbd-client"
14
Adriana Kobylak2fae8ec2018-09-24 14:27:15 -050015S = "${WORKDIR}/git"
16
17SRC_URI = "git://github.com/openbmc/jsnbd"
Andrew Geisslerfa748ad2020-03-31 00:30:57 +000018SRCREV = "74c8a728212021e750686f4ec797e5f16283168a"
Adriana Kobylak329a8052018-10-24 13:31:40 -050019
20NBD_PROXY_CONFIG_JSON ??= "${S}/config.sample.json"
21
22do_install_append() {
23 install -d ${D}${sysconfdir}/nbd-proxy/
24 install -m 0644 ${NBD_PROXY_CONFIG_JSON} ${D}${sysconfdir}/nbd-proxy/config.json
25}