Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "PNG image format decoding library" |
| 2 | HOMEPAGE = "http://www.libpng.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Libpng" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b0085051bf265bac2bfc38bc89f50000\ |
| 6 | file://png.h;endline=144;md5=8acd23d544623816b097e07be0139509\ |
| 7 | " |
| 8 | DEPENDS = "zlib" |
| 9 | |
| 10 | LIBV = "16" |
| 11 | |
| 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/${PV}/${BP}.tar.xz" |
| 13 | SRC_URI[md5sum] = "015e8e15db1eecde5f2eb9eb5b6e59e9" |
| 14 | SRC_URI[sha256sum] = "505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca" |
| 15 | |
| 16 | MIRRORS += "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/${PV}/ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/older-releases/${PV}/" |
| 17 | |
| 18 | UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html" |
| 19 | |
| 20 | BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" |
| 21 | |
| 22 | inherit autotools binconfig-disabled pkgconfig |
| 23 | |
| 24 | # Work around missing symbols |
| 25 | EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off" ,d)}" |
| 26 | |
| 27 | PACKAGES =+ "${PN}-tools" |
| 28 | |
| 29 | FILES_${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |
Brad Bishop | 1d80a2e | 2019-11-15 16:35:03 -0500 | [diff] [blame] | 32 | |
| 33 | # CVE-2019-17371 is actually a memory leak in gif2png 2.x |
| 34 | CVE_CHECK_WHITELIST += "CVE-2019-17371" |