blob: 5b63e49cb5f21db373d191163675e5b7c161dda8 [file] [log] [blame]
Spencer Ku04d737c2020-04-20 15:24:35 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
3
4inherit autotools pkgconfig
5inherit systemd
6
7S = "${WORKDIR}/git"
8SRC_URI = "git://github.com/quanta-bmc/mac-address.git;protocol=git"
9SRCREV = "08b87370c56ff69df852eca87391ae46c05d437a"
10
11DEPENDS += "autoconf-archive-native"
12DEPENDS += "systemd"
13
14FILES_${PN} += "${bindir}/mac-address"
15
16SYSTEMD_PACKAGES = "${PN}"
17SYSTEMD_SERVICE_${PN} = "mac-address.service"
18
19EXTRA_OECONF = " \
20 SYSTEMD_TARGET="multi-user.target" \
21"