blob: 70857591f8707d764a1ed9bc685037fdeb5e15ff [file] [log] [blame]
Brad Bishop37653df2017-05-12 13:02:56 -04001SUMMARY = "Phosphor OpenBMC event and error logging"
2DESCRIPTION = "An error and event log daemon application, and \
3 supporting tools for OpenBMC."
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05004HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
Brad Bishop75f03872018-11-03 09:41:57 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05007DEPENDS += "systemd"
Matt Spinler017f9422020-03-13 15:57:29 -05008DEPENDS += "${PYTHON_PN}-mako-native"
9DEPENDS += "${PYTHON_PN}-pyyaml-native"
10DEPENDS += "${PYTHON_PN}-native"
Patrick Williams4b32c9a2020-03-31 16:43:15 -050011DEPENDS += "${PYTHON_PN}-sdbus++-native"
12DEPENDS += "sdbusplus"
Patrick Williamsadd93832020-06-10 06:52:05 -050013DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050014DEPENDS += "virtual/phosphor-logging-callouts"
Brad Bishop17c08bf2018-10-18 17:07:53 -040015DEPENDS += "libcereal"
Matt Spinlerf319ea62019-07-23 16:04:04 -050016DEPENDS += "sdeventplus"
Patrick Williams60c49072021-04-16 14:14:26 -050017DEPENDS += "packagegroup-obmc-yaml-providers"
Andrew Geisslerfaaf5b32023-01-18 11:40:38 -060018SRCREV = "32a6df6c2b7321f2a5a96533ca0fe00404a4ec38"
Patrick Williams2d52a382021-04-30 10:27:59 -050019PACKAGECONFIG ??= ""
Matt Spinlerf8510922019-08-08 13:21:24 -050020PACKAGECONFIG[openpower-pels] = " \
Patrick Williams2d52a382021-04-30 10:27:59 -050021 -Dopenpower-pel-extension=enabled, \
22 -Dopenpower-pel-extension=disabled, \
Manojkiran Edac5934752022-09-27 13:59:35 -050023 nlohmann-json cli11 libpldm python3, \
Harisuddin Mohamed Isacdfe38f2020-06-05 16:47:37 +080024 python3, \
Matt Spinlerf8510922019-08-08 13:21:24 -050025 "
Ed Tanous9936f862022-09-19 09:13:20 -070026PV = "1.0+git${SRCPV}"
27PR = "r1"
28
29SRC_URI += "git://github.com/openbmc/phosphor-logging;branch=master;protocol=https"
30
31SYSTEMD_PACKAGES = "${LOGGING_PACKAGES}"
32S = "${WORKDIR}/git"
33
34inherit pkgconfig meson
35inherit python3native
36inherit obmc-phosphor-dbus-service
37inherit phosphor-logging
38inherit phosphor-dbus-yaml
Matt Spinlerf8510922019-08-08 13:21:24 -050039
Patrick Williams2d52a382021-04-30 10:27:59 -050040EXTRA_OEMESON = " \
William A. Kennington IIIefe03c32021-05-29 14:55:41 -070041 -Dtests=disabled \
Patrick Williams2d52a382021-04-30 10:27:59 -050042 -Dyamldir=${STAGING_DIR_TARGET}${yaml_dir} \
43 -Dcallout_yaml=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
Deepak Kodihalli1f09d4a2017-03-16 06:32:12 -050044 "
Ed Tanous9936f862022-09-19 09:13:20 -070045
46FILES:${PN}-test = "${bindir}/*-test"
47FILES:${PN}-base += " \
48 ${datadir}/dbus-1 \
49 ${bindir}/phosphor-log-manager \
50 ${libdir}/libphosphor_logging.so.* \
51"
52FILES:phosphor-rsyslog-config += " \
53 ${bindir}/phosphor-rsyslog-conf \
54"
55
56ALLOW_EMPTY:${PN} = "1"
57
58USERADD_PACKAGES = "${PN}-base"
59
60PACKAGE_BEFORE_PN = "${PN}-test"
61# Package configuration
62LOGGING_PACKAGES = " \
63 ${PN}-base \
64 phosphor-rsyslog-config \
65"
66PACKAGE_BEFORE_PN += "${LOGGING_PACKAGES}"
67DBUS_PACKAGES = "${LOGGING_PACKAGES}"
68GROUPADD_PARAM:${PN}-base = "-r phosphor-logging"
69DBUS_SERVICE:${PN}-base += "xyz.openbmc_project.Logging.service"
70DBUS_SERVICE:phosphor-rsyslog-config += "xyz.openbmc_project.Syslog.Config.service"