Benjamin Fair | e43b203 | 2019-09-16 11:32:43 -0700 | [diff] [blame] | 1 | SUMMARY = "XML-based binary image generator" |
| 2 | DESCRIPTION = "XML-based binary image generator" |
| 3 | HOMEPAGE = "https://github.com/Nuvoton-Israel/bingo" |
| 4 | PR = "r1" |
| 5 | PV = "0.1+git${SRCPV}" |
Oshri Alkoby (NTIL) | a85957f | 2019-01-19 00:00:10 +0200 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 8 | |
| 9 | SRC_URI += "git://github.com/Nuvoton-Israel/bingo" |
| 10 | SRC_URI += "file://BootBlockAndHeader_EB.xml" |
| 11 | SRC_URI += "file://UbootHeader_EB.xml" |
| 12 | SRC_URI += "file://mergedBootBlockAndUboot.xml" |
| 13 | |
| 14 | SRCREV = "4f102ff7851da9fd11965857edd1b3046c187b7a" |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | do_install () { |
| 19 | |
| 20 | install -d "${D}${bindir}" |
| 21 | install deliverables/linux/Release/bingo ${D}${bindir} |
| 22 | install ${WORKDIR}/*.xml ${D}${bindir} |
| 23 | } |
| 24 | |
| 25 | inherit native |