blob: b209de16a4b383e1b4e5d1aed046a454f9b8e4f1 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Simple Go-based setuid+setgid+setgroups+exec"
2HOMEPAGE = "https://github.com/tianon/gosu"
3DESCRIPTION = "This is a simple tool grown out of the simple fact that su and sudo have very strange and often annoying TTY and signal-forwarding behavior."
4LICENSE = "Apache-2.0 "
5LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7GO_IMPORT = "github.com/tianon/gosu"
8SRC_URI = "git://${GO_IMPORT}.git;branch=master;protocol=https \
9 git://github.com/opencontainers/runc;name=runc;destsuffix=${S}/src/github.com/opencontainers/runc;branch=main;protocol=https \
10"
Patrick Williams520786c2023-06-25 16:20:36 -050011SRCREV = "0e7347714352cd7f2e5edc9d2cf838d9934e6036"
12#v1.1.0
13SRCREV_runc = "067aaf8548d78269dcb2c13b856775e27c410f9c"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014inherit go
15
Patrick Williams520786c2023-06-25 16:20:36 -050016CGO_ENABLED = "1"
17
Andrew Geissler9aee5002022-03-30 16:27:02 +000018do_compile:prepend() {
19 # New Go versions has Go modules support enabled by default
20 export GO111MODULE=off
21}
22
23RDEPENDS:${PN}-dev += "bash"