blob: 7c847f2eda24db90bf6ca89c3193c000eeebb78f [file] [log] [blame]
Benjamin Faire43b2032019-09-16 11:32:43 -07001SUMMARY = "Primary bootloader for NPCM7XX (Poleg) devices"
2DESCRIPTION = "Primary bootloader for NPCM7XX (Poleg) devices"
3HOMEPAGE = "https://github.com/Nuvoton-Israel/npcm7xx-bootblock"
Oshri Alkoby (NTIL)a85957f2019-01-19 00:00:10 +02004LICENSE = "CLOSED"
5LIC_FILES_CHKSUM = ""
6
Benjamin Faire43b2032019-09-16 11:32:43 -07007SRCREV = "${PV}"
Oshri Alkoby (NTIL)a85957f2019-01-19 00:00:10 +02008FILENAME = "Poleg_bootblock.bin"
9
10SRC_URI = "git://github.com/Nuvoton-Israel/npcm7xx-bootblock;protocol=git"
11SRC_URI[md5sum] = "cf8daa5f4636ed1ff952618e435af028"
12
13S = "${WORKDIR}/git"
14
15inherit deploy
16
17do_deploy () {
18 install -d ${DEPLOYDIR}
19 install -m 644 ${FILENAME} ${DEPLOYDIR}/
20}
21
22addtask deploy before do_build after do_compile