blob: 0e32a4268d28c7fc091a62111daf3d02f56161ed [file] [log] [blame]
Deepak Kodihallif7a1a782017-02-20 00:21:12 -06001SUMMARY = "FRU properties config for openpower-vpd-parser"
2PR = "r1"
Brad Bishopfc00c752018-11-05 19:28:01 -08003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Deepak Kodihallif7a1a782017-02-20 00:21:12 -06005
6inherit native
Deepak Kodihallif7a1a782017-02-20 00:21:12 -06007inherit openpower-fru-vpd
Matt Spinler0a8ea632017-12-14 13:31:55 -06008inherit mrw-xml
Deepak Kodihallif7a1a782017-02-20 00:21:12 -06009
10SRC_URI += "file://config.yaml"
11
12DEPENDS += " \
13 mrw-native \
14 mrw-perl-tools-native \
15 "
16
17PROVIDES += "virtual/openpower-fru-properties"
18
19S = "${WORKDIR}"
20
21do_install() {
22 DEST=${D}${properties_datadir}
23 install -d ${DEST}
24
25 ${bindir}/perl-native/perl \
26 ${bindir}/gen_fru_properties.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060027 -m ${mrw_datadir}/${MRW_XML} \
Deepak Kodihallif7a1a782017-02-20 00:21:12 -060028 -c config.yaml \
29 -o ${DEST}/out.yaml
30}