blob: 0bf1ff14a8eed1ddfdcadf8ffe49afc41fa2d13d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Provides a wrapper in Python to LDAP"
2DESCRIPTION = "This module provides access to the LDAP \
3(Lightweight Directory Access Protocol) through Python operations \
4instead of C API. The module mainly acts as a wrapper for the \
5OpenLDAP 2.x libraries. Errors will appear as exceptions."
6HOMEPAGE = "http://www.python-ldap.org/"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007LICENSE = "PSF-2.0"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
9
10DEPENDS = "python3 openldap cyrus-sasl"
11
12PYPI_PACKAGE = "python-ldap"
13
14inherit pypi setuptools3
15
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016SRC_URI[sha256sum] = "ab26c519a0ef2a443a2a10391fa3c5cb52d7871323399db949ebfaa9f25ee2a0"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
18do_configure:prepend() {
19 sed -i -e 's:^library_dirs =.*::' \
20 -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' \
21 -e 's/= ldap_r/= ldap/g' ${S}/setup.cfg
22}
23
24RDEPENDS:${PN} = " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050025 python3-pprint \
26 python3-pyasn1 \
27 python3-pyasn1-modules \
28 python3-threading \
29 python3-unittest \
Andrew Geissler595f6302022-01-24 19:11:47 +000030"