blob: f88b4ae5b890158150ac3ccc7546161cd039cd4f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Avoid code duplication in bluetooth-dependent recipes.
2
3# Define a variable that expands to the recipe (package) providing core
4# bluetooth support on the platform:
5# "" if bluetooth is not in DISTRO_FEATURES
6# else "bluez5" if bluez5 is in DISTRO_FEATURES
7# else "bluez4"
8
9# Use this with:
10# inherit bluetooth
11# PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', '${BLUEZ}', '', d)}
12# PACKAGECONFIG[bluez4] = "--enable-bluez4,--disable-bluez4,bluez4"
13
14BLUEZ ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5', 'bluez4', d), '', d)}"