blob: e9f3a2aee9b7ed411477ac821e8f2f15cea99b93 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
Brad Bishop316dfdd2018-06-25 12:45:53 -04009SRC_URI = "git://salsa.debian.org/debian/ifupdown.git;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://inet-6-.defn-fix-inverted-checks-for-loopback.patch \
12 file://99_network \
13 "
14SRCREV = "11b9f99f7ecc7052497e6786156cfed531f11823"
15
16S = "${WORKDIR}/git"
17
18
19inherit update-alternatives
20
21do_compile () {
22 chmod a+rx *.pl *.sh
23 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
24}
25
26do_install () {
27 install -d ${D}${mandir}/man8 \
28 ${D}${mandir}/man5 \
29 ${D}${base_sbindir}
30
31 # If volatiles are used, then we'll also need /run/network there too.
32 install -d ${D}/etc/default/volatiles
33 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
34
35 install -m 0755 ifup ${D}${base_sbindir}/
36 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
37 install -m 0644 ifup.8 ${D}${mandir}/man8
38 install -m 0644 interfaces.5 ${D}${mandir}/man5
39 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
40}
41
42ALTERNATIVE_PRIORITY = "100"
43ALTERNATIVE_${PN} = "ifup ifdown"
44
45ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
46ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"