Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for managing memory technology devices" |
| 2 | HOMEPAGE = "http://www.linux-mtd.infradead.org/" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPLv2+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 6 | file://include/common.h;beginline=1;endline=17;md5=ba05b07912a44ea2bf81ce409380049c" |
| 7 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 8 | inherit autotools pkgconfig update-alternatives |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 9 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | DEPENDS = "zlib e2fsprogs util-linux" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | RDEPENDS_mtd-utils-tests += "bash" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 13 | PV = "2.1.0+${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 15 | SRCREV = "b5027be5f470830ac9543db3c52e076b13abd313" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | SRC_URI = "git://git.infradead.org/mtd-utils.git \ |
| 17 | file://add-exclusion-to-mkfs-jffs2-git-2.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | " |
| 19 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | S = "${WORKDIR}/git/" |
| 21 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | EXTRA_OECONF += "--enable-install-tests" |
| 23 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 24 | # xattr support creates an additional compile-time dependency on acl because |
| 25 | # the sys/acl.h header is needed. libacl is not needed and thus enabling xattr |
| 26 | # regardless whether acl is enabled or disabled in the distro should be okay. |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 27 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'xattr', d)} lzo jffs ubifs" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | PACKAGECONFIG[lzo] = "--with-lzo,--without-lzo,lzo" |
| 29 | PACKAGECONFIG[xattr] = "--with-xattr,--without-xattr,acl" |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 30 | PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,openssl" |
| 31 | PACKAGECONFIG[jffs] = "--with-jffs,--without-jffs" |
| 32 | PACKAGECONFIG[ubifs] = "--with-ubifs,--without-ubifs" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 33 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | CPPFLAGS_append_riscv64 = " -pthread -D_REENTRANT" |
| 35 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 36 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} ${@bb.utils.contains('PACKAGECONFIG', 'xattr', '', '-DWITHOUT_XATTR', d)} -I${S}/include' 'BUILDDIR=${S}'" |
| 37 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 38 | # Use higher priority than corresponding BusyBox-provided applets |
| 39 | ALTERNATIVE_PRIORITY = "100" |
| 40 | |
| 41 | ALTERNATIVE_${PN} = "flashcp flash_eraseall flash_lock flash_unlock nanddump nandwrite" |
| 42 | ALTERNATIVE_${PN}-ubifs = "ubiattach ubidetach ubimkvol ubirename ubirmvol ubirsvol ubiupdatevol" |
| 43 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 44 | ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | ALTERNATIVE_LINK_NAME[nandwrite] = "${sbindir}/nandwrite" |
| 46 | ALTERNATIVE_LINK_NAME[nanddump] = "${sbindir}/nanddump" |
| 47 | ALTERNATIVE_LINK_NAME[ubiattach] = "${sbindir}/ubiattach" |
| 48 | ALTERNATIVE_LINK_NAME[ubiattach] = "${sbindir}/ubiattach" |
| 49 | ALTERNATIVE_LINK_NAME[ubidetach] = "${sbindir}/ubidetach" |
| 50 | ALTERNATIVE_LINK_NAME[ubimkvol] = "${sbindir}/ubimkvol" |
| 51 | ALTERNATIVE_LINK_NAME[ubirename] = "${sbindir}/ubirename" |
| 52 | ALTERNATIVE_LINK_NAME[ubirmvol] = "${sbindir}/ubirmvol" |
| 53 | ALTERNATIVE_LINK_NAME[ubirsvol] = "${sbindir}/ubirsvol" |
| 54 | ALTERNATIVE_LINK_NAME[ubiupdatevol] = "${sbindir}/ubiupdatevol" |
| 55 | ALTERNATIVE_LINK_NAME[flash_eraseall] = "${sbindir}/flash_eraseall" |
| 56 | ALTERNATIVE_LINK_NAME[flash_lock] = "${sbindir}/flash_lock" |
| 57 | ALTERNATIVE_LINK_NAME[flash_unlock] = "${sbindir}/flash_unlock" |
| 58 | ALTERNATIVE_LINK_NAME[flashcp] = "${sbindir}/flashcp" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 59 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 60 | do_install () { |
| 61 | oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} INCLUDEDIR=${includedir} |
| 62 | } |
| 63 | |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 64 | PACKAGES =+ "mtd-utils-misc mtd-utils-tests" |
| 65 | PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "jffs", "mtd-utils-jffs2", "", d)}" |
| 66 | PACKAGES =+ "${@bb.utils.contains("PACKAGECONFIG", "ubifs", "mtd-utils-ubifs", "", d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 67 | |
| 68 | FILES_mtd-utils-jffs2 = "${sbindir}/mkfs.jffs2 ${sbindir}/jffs2dump ${sbindir}/jffs2reader ${sbindir}/sumtool" |
| 69 | FILES_mtd-utils-ubifs = "${sbindir}/mkfs.ubifs ${sbindir}/ubi*" |
| 70 | FILES_mtd-utils-misc = "${sbindir}/nftl* ${sbindir}/ftl* ${sbindir}/rfd* ${sbindir}/doc* ${sbindir}/serve_image ${sbindir}/recv_image" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 71 | FILES_mtd-utils-tests = "${libexecdir}/mtd-utils/*" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 72 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 73 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 74 | |
| 75 | # git/.compr.c.dep:46: warning: NUL character seen; rest of line ignored |
| 76 | # git/.compr.c.dep:47: *** missing separator. Stop. |
| 77 | PARALLEL_MAKE = "" |