blob: 55ee277606a2230d99158f3aff427a066e932fcb [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "GTK+2 standard themes"
2HOMEPAGE = "http://ftp.gnome.org/pub/GNOME/sources/gnome-themes-standard/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome"
5
6LICENSE = "LGPL-2.1"
7LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
8
9inherit autotools pkgconfig gettext gtk-icon-cache upstream-version-is-even distro_features_check
10
11ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
12
13DEPENDS += "intltool-native gtk+"
14
15MAJ_VER = "${@oe.utils.trim_version("${PV}", 2)}"
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${MAJ_VER}/${BPN}-${PV}.tar.xz \
17 "
18
19SRC_URI[md5sum] = "b51c362b157b6407303d44f93c31ee11"
20SRC_URI[sha256sum] = "61dc87c52261cfd5b94d65e8ffd923ddeb5d3944562f84942eeeb197ab8ab56a"
21
22EXTRA_OECONF = "--disable-gtk3-engine"
23
24do_install_append() {
25 # Only building Adwaita, remove highcontrast files
26 rm -rf ${D}${prefix}/share/themes/HighContrast \
27 ${D}${prefix}/share/icons
28
29 # The libtool archive file is unneeded with shared libs on modern Linux
30 rm -rf ${D}${libdir}/gtk-2.0/2.10.0/engines/libadwaita.la
31}
32
33# There could be gnome-theme-highcontrast as well but that requires
34# gtk+3 and includes lots of icons (is also broken with B != S).
35PACKAGES += "gnome-theme-adwaita \
36 gnome-theme-adwaita-dark \
37 "
38
39FILES_gnome-theme-adwaita = "${prefix}/share/themes/Adwaita \
40 ${libdir}/gtk-2.0/2.10.0/engines/libadwaita.so"
41
42FILES_gnome-theme-adwaita-dark = "${prefix}/share/themes/Adwaita-dark"
43RDEPENDS_gnome-theme-adwaita-dark = "gnome-theme-adwaita"
44
45# gnome-themes-standard is empty and doesn't exist
46RDEPENDS_${PN}-dev = ""