Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "An HTTP library implementation in C" |
| 2 | DESCRIPTION = "libsoup is an HTTP client/server library for GNOME. It uses GObjects \ |
| 3 | and the glib main loop, to integrate well with GNOME applications." |
| 4 | HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup" |
| 5 | BUGTRACKER = "https://bugzilla.gnome.org/" |
| 6 | SECTION = "x11/gnome/libs" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 7 | LICENSE = "LGPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2" |
| 9 | |
| 10 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 libpsl" |
| 11 | |
| 12 | SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}" |
| 13 | |
| 14 | SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz" |
| 15 | SRC_URI[sha256sum] = "f0a427656e5fe19e1df71c107e88dfa1b2e673c25c547b7823b6018b40d01159" |
| 16 | |
| 17 | CVE_PRODUCT = "libsoup" |
| 18 | |
| 19 | S = "${WORKDIR}/libsoup-${PV}" |
| 20 | |
| 21 | inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 22 | |
| 23 | UPSTREAM_CHECK_REGEX = "libsoup-(?P<pver>2(\.(?!99)\d+)+)\.tar" |
| 24 | |
| 25 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 26 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 27 | |
| 28 | # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default. |
| 29 | PACKAGECONFIG ??= "" |
| 30 | PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false" |
| 31 | PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5" |
| 32 | |
| 33 | EXTRA_OEMESON:append = " -Dvapi=disabled -Dtls_check=false" |
| 34 | |
| 35 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 36 | |
| 37 | # When built without gnome support, libsoup-2.4 will contain only one shared lib |
| 38 | # and will therefore become subject to renaming by debian.bbclass. Prevent |
| 39 | # renaming in order to keep the package name consistent regardless of whether |
| 40 | # gnome support is enabled or disabled. |
| 41 | DEBIAN_NOAUTONAME:${PN} = "1" |
| 42 | |
| 43 | # glib-networking is needed for SSL, proxies, etc. |
| 44 | RRECOMMENDS:${PN} = "glib-networking" |
| 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |