blob: d1c96662c66c14e0ab1a82652b2d02f0ad74dfdf [file] [log] [blame]
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
4PR = "r1"
Patrick Venture4f792732018-10-02 20:51:15 -07005PV = "1.0+git${SRCPV}"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05306LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Venture4f792732018-10-02 20:51:15 -07008
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05309inherit autotools pkgconfig
10inherit obmc-phosphor-dbus-service
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph926556d2018-07-10 12:23:06 -050016DEPENDS += "boost"
Andrew Geissler1de95de2018-10-09 04:10:28 +000017DEPENDS += "nss-pam-ldapd"
Brad Bishop44f3cce2019-03-22 23:41:42 -040018DEPENDS += "systemd"
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050019PACKAGE_BEFORE_PN = "phosphor-ldap"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053020
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070021inherit useradd
22
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050023USERADD_PACKAGES = "${PN} phosphor-ldap"
24DBUS_PACKAGES = "${USERADD_PACKAGES}"
Richard Marian Thomaiyara3488602018-04-12 16:06:36 -070025# add groups needed for privilege maintenance
26GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback "
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050027GROUPADD_PARAM_phosphor-ldap = "priv-admin; priv-operator; priv-user; priv-callback "
Richard Marian Thomaiyar7a8e9b22018-12-14 09:04:40 +053028
29# Add root user to priv-admin group
30GROUPMEMS_PARAM_${PN} = "-g priv-admin -a root"
31
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053032DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service"
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050033FILES_phosphor-ldap += " \
Patrick Ventured8014ce2019-04-04 10:03:09 -070034 ${bindir}/phosphor-ldap-conf \
35 ${bindir}/phosphor-ldap-mapper \
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050036"
Tom Joseph42276262018-10-07 05:51:04 -050037DBUS_SERVICE_phosphor-ldap = " \
38 xyz.openbmc_project.Ldap.Config.service \
39 xyz.openbmc_project.LDAP.PrivilegeMapper.service \
40"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053041SRC_URI += "git://github.com/openbmc/phosphor-user-manager"
Andrew Geissler5f50f0e2019-09-30 13:51:31 +000042SRCREV = "7c6e7cffaf061aabfe5489ef52442e2f7cbd0fb7"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053043S = "${WORKDIR}/git"