Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Framework for defining and tracking users, login sessions, and seats" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "It provides a mechanism for software to react to changes \ |
| 3 | of any of these items or of any of the metadata associated with them." |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ConsoleKit" |
| 5 | BUGTRACKER = "https://bugs.freedesktop.org/buglist.cgi?query_format=specific&product=ConsoleKit" |
| 6 | |
| 7 | LICENSE = "GPLv2+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
| 9 | file://src/main.c;endline=21;md5=0a994e09769780220163255d8f9071c3" |
| 10 | |
| 11 | DEPENDS = "glib-2.0 glib-2.0-native dbus dbus-glib virtual/libx11" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 12 | RDEPENDS:${PN} += "base-files" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 14 | inherit autotools pkgconfig features_check |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | # depends on virtual/libx11 |
| 16 | REQUIRED_DISTRO_FEATURES = "x11" |
| 17 | |
| 18 | SRC_URI = "http://www.freedesktop.org/software/ConsoleKit/dist/ConsoleKit-${PV}.tar.xz \ |
| 19 | file://sepbuildfix.patch \ |
| 20 | file://add-polkit-configure-argument.patch \ |
| 21 | " |
| 22 | |
| 23 | SRC_URI[md5sum] = "611792b4d616253a5bdec9175f8b7678" |
| 24 | SRC_URI[sha256sum] = "b41d17e06f80059589fbeefe96ad07bcc564c49e65516da1caf975146475565c" |
| 25 | |
| 26 | S = "${WORKDIR}/ConsoleKit-${PV}" |
| 27 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd polkit', d)}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | |
| 30 | PACKAGECONFIG[pam] = "--enable-pam-module --with-pam-module-dir=${base_libdir}/security,--disable-pam-module,libpam" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 32 | PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--with-systemdsystemunitdir=" |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN} += "${exec_prefix}/lib/ConsoleKit \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 35 | ${libdir}/ConsoleKit ${systemd_unitdir} ${base_libdir} \ |
| 36 | ${datadir}/dbus-1 ${datadir}/PolicyKit ${datadir}/polkit*" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 37 | |
| 38 | PACKAGES =+ "pam-plugin-ck-connector" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:pam-plugin-ck-connector += "${base_libdir}/security/*.so" |
| 40 | RDEPENDS:pam-plugin-ck-connector += "${PN}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | do_install:append() { |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 43 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 44 | install -d ${D}${sysconfdir}/tmpfiles.d |
| 45 | echo "d ${localstatedir}/log/ConsoleKit - - - -" \ |
| 46 | > ${D}${sysconfdir}/tmpfiles.d/consolekit.conf |
| 47 | fi |
| 48 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 49 | # Remove /var/ directories as the daemon creates them as required |
| 50 | rm -rf ${D}${localstatedir} |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 51 | } |