Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | # Copyright (C) 2020 Jens Rehsack <sno@netbsd.org> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "Test::Warnings - Test for warnings and the lack of them" |
| 5 | DESCRIPTION = "If you've ever tried to use Test::NoWarnings to confirm there are no \ |
| 6 | warnings generated by your tests, combined with the convenience of \ |
| 7 | \\"done_testing\\" to not have to declare a test count, you'll have discovered \ |
| 8 | that these two features do not play well together, as the test count will \ |
| 9 | be calculated *before* the warnings test is run, resulting in a TAP error. \ |
| 10 | (See "examples/test_nowarnings.pl" in this distribution for a \ |
| 11 | demonstration.)" |
| 12 | HOMEPAGE = "https://github.com/karenetheridge/Test-Warnings" |
| 13 | BUGTRACKER = "https://rt.cpan.org/Public/Dist/Display.html?Name=Test-Warnings" |
| 14 | SECTION = "libs" |
| 15 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
| 16 | |
| 17 | LIC_FILES_CHKSUM = "file://LICENCE;md5=6f2b02f39e7d359efd9525fbc56c84a1" |
| 18 | |
| 19 | SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Test-Warnings-${PV}.tar.gz" |
| 20 | |
| 21 | SRC_URI[sha256sum] = "1e542909fef305e45563e9878ea1c3b0c7cef1b28bb7ae07eba2e1efabec477b" |
| 22 | |
| 23 | S = "${WORKDIR}/Test-Warnings-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
| 27 | RDEPENDS:${PN} += "\ |
| 28 | perl-module-test-builder \ |
| 29 | " |
| 30 | |
| 31 | # Many hidden dependencies and mysterious failures occur without full perl-modules |
| 32 | RDEPENDS:${PN}-ptest += "perl-modules" |
| 33 | |
| 34 | do_install_ptest_perl:append () { |
| 35 | cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/ |
| 36 | chown -R root:root ${D}${PTEST_PATH}/t/lib |
| 37 | } |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |