| # avoids build breaks when using no-static-libs.inc |
| EXTRA_OECONF_append = " ${PACKAGECONFIG_CONFARGS}" |
| def get_waf_parallel_make(d): |
| pm = d.getVar('PARALLEL_MAKE') |
| # look for '-j' and throw other options (e.g. '-l') away |
| # because they might have different meaning in bjam |
| elif opt.startswith('-j'): |
| python waf_preconfigure() { |
| from distutils.version import StrictVersion |
| srcsubdir = d.getVar('S') |
| wafbin = os.path.join(srcsubdir, 'waf') |
| status, result = oe.utils.getstatusoutput(wafbin + " --version") |
| bb.warn("Unable to execute waf --version, exit code %d. Assuming waf version without bindir/libdir support." % status) |
| version = result.split()[1] |
| if StrictVersion(version) >= StrictVersion("1.8.7"): |
| d.setVar("WAF_EXTRA_CONF", "--bindir=${bindir} --libdir=${libdir}") |
| do_configure[prefuncs] += "waf_preconfigure" |
| ${S}/waf configure --prefix=${prefix} ${WAF_EXTRA_CONF} ${EXTRA_OECONF} |
| ${S}/waf build ${@get_waf_parallel_make(d)} |
| ${S}/waf install --destdir=${D} |
| EXPORT_FUNCTIONS do_configure do_compile do_install |