blob: 9f7d5b0b61045addd78e9683d96e4b8f0a9e826f [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001DESCRIPTION = "jackdmp is a C++ version of the JACK low-latency audio \
2server for multi-processor machines. It is a new implementation of the \
3JACK server core features that aims in removing some limitations of \
4the JACK1 design. The activation system has been changed for a data \
5flow model and lock-free programming techniques for graph access have \
6been used to have a more dynamic and robust system."
7SECTION = "libs/multimedia"
8
9LICENSE = "GPLv2 & LGPLv2.1"
10LIC_FILES_CHKSUM = " \
11 file://common/jack/control.h;beginline=2;endline=21;md5=e6df0bf30cde8b3b825451459488195d \
12 file://common/jack/jack.h;beginline=1;endline=19;md5=6b736ed6b810592b135480a5e853392e \
13"
14
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015DEPENDS = "libsamplerate0 libsndfile1 readline"
Patrick Williamsddad1a12017-02-23 20:36:32 -060016
Brad Bishop00ab2372019-10-14 11:06:18 -040017SRC_URI = "git://github.com/jackaudio/jack2.git"
18SRCREV = "37250ff470277f9947fbf3ba738f943053e30525"
19PV = "1.9.13"
Patrick Williamsddad1a12017-02-23 20:36:32 -060020S = "${WORKDIR}/git"
21
22inherit waf pkgconfig
23
24PACKAGECONFIG ??= "alsa"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025PACKAGECONFIG[alsa] = "--alsa=yes,--alsa=no,alsa-lib"
Brad Bishop19323692019-04-05 15:28:33 -040026# --dbus only stops building jackd -> add --classic
27PACKAGECONFIG[dbus] = "--dbus --classic,,dbus"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028PACKAGECONFIG[opus] = "--opus=yes,--opus=no,libopus"
Patrick Williamsddad1a12017-02-23 20:36:32 -060029
30# portaudio is for windows builds only
31EXTRA_OECONF = "--portaudio=no"
32
33PACKAGES =+ "libjack jack-server jack-utils"
34
Brad Bishop6e60e8b2018-02-01 10:27:11 -050035RDEPENDS_jack-dev_remove = "${PN} (= ${EXTENDPKGV})"
36
Patrick Williamsddad1a12017-02-23 20:36:32 -060037FILES_libjack = "${libdir}/*.so.* ${libdir}/jack/*.so"
Brad Bishop19323692019-04-05 15:28:33 -040038FILES_jack-server = " \
39 ${datadir}/dbus-1/services \
40 ${bindir}/jackdbus \
41 ${bindir}/jackd \
42"
Patrick Williamsddad1a12017-02-23 20:36:32 -060043FILES_jack-utils = "${bindir}/*"
Brad Bishop19323692019-04-05 15:28:33 -040044
Patrick Williamsddad1a12017-02-23 20:36:32 -060045FILES_${PN}-doc += " ${datadir}/jack-audio-connection-kit/reference/html/* "