blob: b6e0c92f6d720eb82626b831879966420422713b [file] [log] [blame]
Brad Bishop36a3e3e2019-10-02 13:29:27 -04001SUMMARY = "RenderDoc recipe providing renderdoccmd"
2DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
3HOMEPAGE = "https://github.com/baldurk/renderdoc"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9753b1b4fba3261c27d1ce5c1acef667"
6
7SRCREV = "214d85228538e71cc63a0d7fa11dd75b1d56cc81"
8SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
9 file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
10"
11S = "${WORKDIR}/git"
12
13DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
14
15RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
16
17inherit cmake python3native
18
19python __anonymous () {
20 # only works on glibc systems
21 if d.getVar('TCLIBC') != "glibc":
22 raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
23}
24
25COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
26
27EXTRA_OECMAKE += "\
28 -DENABLE_QRENDERDOC=OFF \
29 -DENABLE_PYRENDERDOC=OFF \
30 -DENABLE_RENDERDOCCMD=ON \
31 -DCMAKE_BUILD_TYPE=Release \
32"
33
34FILES_${PN} += "${libdir}"
35FILES_${PN}-dev = "${includedir}"