Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "C++/Boost Asio based websocket client/server library." |
| 2 | SECTION = "libs/network" |
| 3 | HOMEPAGE = "https://github.com/zaphoyd/websocketpp" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 6 | |
| 7 | DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 9 | SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \ |
| 10 | file://0001-Replace-make_shared-with-new-in-some-cases.patch \ |
| 11 | file://0002-Fix-missed-entries-fix-testing.patch \ |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 12 | file://0001-cmake-Use-GNUInstallDirs.patch \ |
| 13 | file://842.patch \ |
| 14 | file://771.patch \ |
| 15 | file://855.patch \ |
| 16 | file://857.patch \ |
| 17 | file://0001-Correct-clang-compiler-flags.patch \ |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 18 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 20 | EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} " |
| 21 | |
| 22 | # this is an header only library, do not depend on the main package |
| 23 | RDEPENDS_${PN}-dev = "" |
| 24 | |
| 25 | # to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this: |
| 26 | # TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev" |
| 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | # tag 0.8.1 |
| 29 | SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7" |
| 30 | |
| 31 | S = "${WORKDIR}/git" |
| 32 | |
| 33 | inherit cmake |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 34 | |
| 35 | PACKAGES =+ "${PN}-examples" |
| 36 | |
| 37 | FILES_${PN}-examples = "${docdir}" |
| 38 | |
| 39 | do_install_append() { |
| 40 | install -d ${D}${docdir}/${BPN} |
| 41 | cp -R ${S}/examples ${D}${docdir}/${BPN} |
| 42 | } |