blob: af6d30a281f7e456b643766afcbc75cea7468a96 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "C++/Boost Asio based websocket client/server library."
2SECTION = "libs/network"
3HOMEPAGE = "https://github.com/zaphoyd/websocketpp"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=4d168d763c111f4ffc62249870e4e0ea"
Brad Bishope42b3e32020-01-15 22:08:42 -05006
7DEPENDS = " ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'openssl boost zlib', '', d)} "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Brad Bishop0f291cc2019-09-01 15:16:57 -04009SRC_URI = "git://github.com/zaphoyd/websocketpp.git;protocol=https \
10 file://0001-Replace-make_shared-with-new-in-some-cases.patch \
11 file://0002-Fix-missed-entries-fix-testing.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050012 file://0001-cmake-Use-GNUInstallDirs.patch \
13 file://842.patch \
14 file://771.patch \
15 file://855.patch \
16 file://857.patch \
17 file://0001-Correct-clang-compiler-flags.patch \
Brad Bishop0f291cc2019-09-01 15:16:57 -040018 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019
Brad Bishope42b3e32020-01-15 22:08:42 -050020EXTRA_OECMAKE = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '-DBUILD_EXAMPLES=ON -DBUILD_TESTS=ON', '', d)} "
21
22# this is an header only library, do not depend on the main package
23RDEPENDS_${PN}-dev = ""
24
25# to add this package to an SDK, since it isn't a reverse-dependency of anything, just use something like this:
26# TOOLCHAIN_TARGET_TASK_append = " websocketpp-dev"
27
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028# tag 0.8.1
29SRCREV= "c6d7e295bf5a0ab9b5f896720cc1a0e0fdc397a7"
30
31S = "${WORKDIR}/git"
32
33inherit cmake
Brad Bishope42b3e32020-01-15 22:08:42 -050034
35PACKAGES =+ "${PN}-examples"
36
37FILES_${PN}-examples = "${docdir}"
38
39do_install_append() {
40 install -d ${D}${docdir}/${BPN}
41 cp -R ${S}/examples ${D}${docdir}/${BPN}
42}