Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 1 | SUMMARY = "Physical quantities module" |
| 2 | DESCRIPTION = "Physical quantities Python module" |
| 3 | HOMEPAGE = "https://github.com/hgrecco/pint" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b" |
| 8 | |
| 9 | PYPI_PACKAGE := "Pint" |
| 10 | |
| 11 | inherit pypi ptest setuptools3 |
| 12 | |
| 13 | SRC_URI[md5sum] = "0af699bc0ccdff56228b4a81216b4f7d" |
| 14 | SRC_URI[sha256sum] = "dc899061f9dc478e0aac3b0d872ca33d120efd32c382984818adab3522b6c793" |
| 15 | |
| 16 | DEPENDS += "python3-setuptools-scm-native" |
| 17 | |
| 18 | BBCLASSEXTEND = "native nativesdk" |
| 19 | |
| 20 | SRC_URI += " \ |
| 21 | file://run-ptest \ |
| 22 | " |
| 23 | |
| 24 | RDEPENDS_${PN}-ptest += " \ |
| 25 | ${PYTHON_PN}-pytest \ |
| 26 | " |
| 27 | |
| 28 | do_install_ptest() { |
| 29 | install -d ${D}${PTEST_PATH}/testsuite |
| 30 | cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/ |
| 31 | } |