blob: a286a5adb7b03f33e32cd7aaf48da82944b571c5 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "Parole is a modern simple media player based on the GStreamer framework"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/parole"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5
6inherit xfce-app gtk-doc mime
7
8DEPENDS += " \
9 glib-2.0 \
10 dbus-glib \
11 gtk+3 \
12 \
13 xfce4-dev-tools-native \
14 libxfce4util \
15 libxfce4ui \
16 xfconf \
17 \
18 gstreamer1.0-plugins-base \
19 taglib \
20"
21
22SRC_URI[md5sum] = "cd22ab579470c5728db0aa6c0b9d4c7d"
23SRC_URI[sha256sum] = "bff0fc846d0d7b8f435ac5514976f1cd1d82b62dbf1b7d470e253a5b439407da"
24
25RDEPENDS_${PN} += "gstreamer1.0-plugins-good"
26
27EXTRA_OECONF = "--disable-gtk-doc"
28
29PACKAGECONFIG ??= "notify"
30PACKAGECONFIG[clutter] = "--enable-clutter, --disable-clutter, clutter"
31PACKAGECONFIG[notify] = "--enable-notify-plugin, --disable-notify-plugin, libnotify"
32
33FILES_${PN} += " \
34 ${datadir}/appdata \
35 ${libdir}/parole-0/*.so \
36"