Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "The Apache HTTP Server is a powerful, efficient, and \ |
| 2 | extensible web server." |
| 3 | SUMMARY = "Apache HTTP Server" |
| 4 | HOMEPAGE = "http://httpd.apache.org/" |
| 5 | DEPENDS = "expat-native pcre-native apr-native apr-util-native" |
| 6 | SECTION = "net" |
| 7 | LICENSE = "Apache-2.0" |
| 8 | |
| 9 | inherit autotools pkgconfig native |
| 10 | |
| 11 | SRC_URI = "${APACHE_MIRROR}/httpd/httpd-${PV}.tar.bz2 \ |
| 12 | file://0001-configure-use-pkg-config-for-PCRE-detection.patch \ |
| 13 | file://CVE-2018-11763.patch \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/httpd-${PV}" |
| 17 | |
| 18 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d52d0fd0bc788f068e647116c01ddfcd" |
| 19 | SRC_URI[md5sum] = "818adca52f3be187fe45d6822755be95" |
| 20 | SRC_URI[sha256sum] = "fa53c95631febb08a9de41fd2864cfff815cf62d9306723ab0d4b8d7aa1638f0" |
| 21 | |
| 22 | EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \ |
| 23 | --with-apr-util=${STAGING_BINDIR_CROSS}/apu-1-config \ |
| 24 | --prefix=${prefix} --datadir=${datadir}/apache2 \ |
| 25 | " |
| 26 | |
| 27 | do_install () { |
| 28 | install -d ${D}${bindir} ${D}${libdir} |
| 29 | cp server/gen_test_char ${D}${bindir} |
| 30 | install -m 755 support/apxs ${D}${bindir}/ |
| 31 | install -m 755 httpd ${D}${bindir}/ |
| 32 | install -d ${D}${datadir}/apache2/build |
| 33 | cp ${S}/build/*.mk ${D}${datadir}/apache2/build |
| 34 | cp build/*.mk ${D}${datadir}/apache2/build |
| 35 | cp ${S}/build/instdso.sh ${D}${datadir}/apache2/build |
| 36 | |
| 37 | install -d ${D}${includedir}/apache2 |
| 38 | cp ${S}/include/* ${D}${includedir}/apache2 |
| 39 | cp include/* ${D}${includedir}/apache2 |
| 40 | cp ${S}/os/unix/os.h ${D}${includedir}/apache2 |
| 41 | cp ${S}/os/unix/unixd.h ${D}${includedir}/apache2 |
| 42 | |
| 43 | cp support/envvars-std ${D}${bindir}/envvars |
| 44 | chmod 755 ${D}${bindir}/envvars |
| 45 | } |
| 46 | |