Alexander Filippov | 126f667 | 2018-11-28 11:32:04 +0300 | [diff] [blame] | 1 | SUMMARY = "Init BMC MAC address" |
| 2 | DESCRIPTION = "Setup BMC MAC address read from VPD" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| 6 | |
| 7 | inherit allarch systemd |
| 8 | |
| 9 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}" |
| 10 | |
| 11 | SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service" |
| 12 | |
| 13 | SRC_URI = "file://${PN}.sh file://${PN}@.service" |
| 14 | |
| 15 | S = "${WORKDIR}" |
| 16 | do_install() { |
| 17 | install -d ${D}${bindir} ${D}${systemd_system_unitdir} |
| 18 | install ${PN}.sh ${D}${bindir}/ |
| 19 | install -m 644 ${PN}@.service ${D}${systemd_system_unitdir}/ |
| 20 | } |