Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame^] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
| 14 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 15 | |
| 16 | SRC_URI += "file://run-ptest \ |
| 17 | file://0001-Enforce-recreation-of-docs-pango.types-it-is-build-c.patch \ |
| 18 | " |
| 19 | SRC_URI[archive.md5sum] = "deb171a31a3ad76342d5195a1b5bbc7c" |
| 20 | SRC_URI[archive.sha256sum] = "1d2b74cd63e8bd41961f2f8d952355aa0f9be6002b52c8aa7699d9f5da597c9d" |
| 21 | |
| 22 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 23 | |
| 24 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 25 | PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft" |
| 26 | |
| 27 | LEAD_SONAME = "libpango-1.0*" |
| 28 | LIBV = "1.8.0" |
| 29 | |
| 30 | # This binary needs to be compiled for the host architecture. This isn't pretty! |
| 31 | do_compile_prepend_class-target () { |
| 32 | if ${@bb.utils.contains('PTEST_ENABLED', '1', 'true', 'false', d)}; then |
| 33 | make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="${BUILD_LDFLAGS}" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode |
| 34 | fi |
| 35 | } |
| 36 | |
| 37 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 38 | FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la" |
| 39 | |
| 40 | RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts" |
| 41 | |
| 42 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 43 | pango-module-basic-fc pango-module-arabic-lang" |
| 44 | |
| 45 | BBCLASSEXTEND = "native" |