Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "A high performance, open source, general-purpose RPC framework. \ |
| 2 | Provides gRPC libraries for multiple languages written on top of shared C core library \ |
| 3 | (C++, Node.js, Python, Ruby, Objective-C, PHP, C#)" |
| 4 | HOMEPAGE = "https://github.com/grpc/grpc" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "Apache-2" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 8 | |
| 9 | DEPENDS = "gflags c-ares protobuf protobuf-native protobuf-c protobuf-c-native openssl" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 10 | DEPENDS_append_class-target = " googletest grpc-native " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | DEPENDS_append_class-nativesdk = " grpc-native " |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 14 | SRCREV = "08fd59f039c7cf62614ab7741b3f34527af103c7" |
| 15 | BRANCH = "v1.22.x" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 16 | SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;branch=${BRANCH} \ |
| 17 | file://0001-CMakeLists.txt-Fix-libraries-installation-for-Linux.patch \ |
| 18 | " |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 19 | SRC_URI_append_class-target = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch \ |
| 20 | file://0001-Define-gettid-only-for-glibc-2.30.patch \ |
| 21 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | SRC_URI_append_class-nativesdk = " file://0001-CMakeLists.txt-Fix-grpc_cpp_plugin-path-during-cross.patch" |
| 23 | |
| 24 | # Fixes build with older compilers 4.8 especially on ubuntu 14.04 |
| 25 | CXXFLAGS_append_class-native = " -Wl,--no-as-needed" |
| 26 | |
| 27 | inherit cmake |
| 28 | |
| 29 | EXTRA_OECMAKE = " \ |
| 30 | -DgRPC_CARES_PROVIDER=package \ |
| 31 | -DgRPC_ZLIB_PROVIDER=package \ |
| 32 | -DgRPC_SSL_PROVIDER=package \ |
| 33 | -DgRPC_PROTOBUF_PROVIDER=package \ |
| 34 | -DgRPC_GFLAGS_PROVIDER=package \ |
| 35 | -DgRPC_INSTALL=ON \ |
| 36 | -DCMAKE_CROSSCOMPILING=ON \ |
| 37 | -DBUILD_SHARED_LIBS=ON \ |
| 38 | " |
| 39 | |
| 40 | BBCLASSEXTEND = "native nativesdk" |
| 41 | |
| 42 | SYSROOT_DIRS_BLACKLIST_append_class-target = "${libdir}/cmake/grpc" |
| 43 | |
| 44 | FILES_${PN}-dev += "${bindir}" |