Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 1 | SUMMARY = "Boost.Build" |
| 2 | SECTION = "devel" |
| 3 | |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 6 | |
| 7 | SRC_URI = "git://github.com/boostorg/build;protocol=https" |
| 8 | SRCREV = "632ea768f3eb225b4472c5ed6d20afee708724ad" |
| 9 | |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 10 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+){2,}))" |
| 11 | |
Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 12 | inherit native |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_compile() { |
| 17 | ./bootstrap.sh |
| 18 | } |
| 19 | |
| 20 | do_install() { |
| 21 | ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix} |
| 22 | } |
| 23 | |
| 24 | # The build is either release mode (pre-stripped) or debug (-O0). |
| 25 | INSANE_SKIP_${PN} = "already-stripped" |