blob: 258f8c9cdf60cf783d32e97cba36ff35714a03c4 [file] [log] [blame]
Andrew Geisslerf0343792020-11-18 10:42:21 -06001SUMMARY = "Boost.Build"
2SECTION = "devel"
3
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
6
7SRC_URI = "git://github.com/boostorg/build;protocol=https"
8SRCREV = "632ea768f3eb225b4472c5ed6d20afee708724ad"
9
Andrew Geissler4c19ea12020-10-27 13:52:24 -050010UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+){2,}))"
11
Andrew Geisslerf0343792020-11-18 10:42:21 -060012inherit native
13
14S = "${WORKDIR}/git"
15
16do_compile() {
17 ./bootstrap.sh
18}
19
20do_install() {
21 ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix}
22}
23
24# The build is either release mode (pre-stripped) or debug (-O0).
25INSANE_SKIP_${PN} = "already-stripped"