Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require gdb.inc |
| 2 | require gdb-${PV}.inc |
| 3 | |
| 4 | inherit python-dir |
| 5 | |
| 6 | do_configure_prepend() { |
| 7 | if [ -n "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python', '', d)}" ]; then |
| 8 | cat > ${WORKDIR}/python << EOF |
| 9 | #!/bin/sh |
| 10 | case "\$2" in |
| 11 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}/" ;; |
| 12 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}" ;; |
| 13 | --exec-prefix) echo "${exec_prefix}" ;; |
| 14 | *) exit 1 ;; |
| 15 | esac |
| 16 | exit 0 |
| 17 | EOF |
| 18 | chmod +x ${WORKDIR}/python |
| 19 | fi |
| 20 | } |